Transactions page skipping results when changing pages

Incident Report for Tithe.ly

Resolved

We’re back! The Giving Transactions page should be up and running. Thanks for bearing with us.
Posted Feb 17, 2026 - 14:52 PST

Monitoring

The GIving transactions page appears to be back up and running. We’re monitoring it closely to verify all issues are fully resolved. We’ll share another update shortly.
Posted Feb 17, 2026 - 14:39 PST

Update

Work continues on implementing a fix for this issue. The current workaround for this is to add a date filter to the Transactions page and all transactions will be visible through page changes.
Posted Feb 17, 2026 - 11:58 PST

Update

We’ve identified the issue causing the problem and are working to fix this as quickly as we can. We’ll share another update shortly. The current workaround for this is to add a date filter to the Transactions page and all transactions will be visible through page changes.
Posted Feb 17, 2026 - 08:07 PST

Identified

Our teams are aware of an issue where transactions are being skipped in the view of transactions when NOT using a date filter. The current workaround for this is to add a date filter to the Transactions page and all transactions will be visible through page changes.
Posted Feb 17, 2026 - 07:45 PST
This incident affected: Admin Experience.