Identified Partial Outage for Android Giving App

Incident Report for Tithe.ly

Resolved

We’re back! Giving App on Android should be up and running. Users can update to version 3.5.3 in the Play Store to get the restored functionality. Thanks for bearing with us.
Posted Jan 29, 2026 - 12:25 PST

Monitoring

Giving App on Android appears to be back up and running. We’re monitoring it closely to verify all issues are fully resolved. We’ll share another update shortly.
Posted Jan 29, 2026 - 12:17 PST

Identified

We’ve identified the issue causing the problem and are working to fix this as quickly as we can. We’ll share another update shortly.
Posted Jan 29, 2026 - 11:17 PST
This incident affected: Giving (Giving App, Form, Transaction Processing).