Giving Dashboard has incorrect data.

Incident Report for Tithe.ly

Update

We’ve identified the issue causing the problem and are working to fix this as quickly as we can. We’ll share another update shortly.
Posted Feb 17, 2026 - 14:43 PST

Identified

Our teams are aware of an issue affecting the Giving Dashboard where it is not showing the full results of data. Engineering teams are working to resolve this.
Posted Feb 17, 2026 - 07:39 PST
This incident affects: Admin Experience and Giving (Transaction Reporting).