Issues Generating Tax Statements

Incident Report for Tithe.ly

Resolved

The issue affecting the generation of tax statements has been fully resolved by our Engineering teams. Thanks for your patience while we needed to work through this and ensure things are working as expected for you!
Posted Nov 30, 2023 - 17:02 PST

Investigating

Our teams have been investigating issues generating tax statements and we are now escalating this to an incident for visibility.
Posted Nov 27, 2023 - 08:04 PST
This incident affected: Admin Experience.