Issues with Admin Experience
Incident Report for Tithe.ly
Resolved
We're happy to report that everything has returned to normal and things are working as expected. Thank you for your patience!
Posted Jul 25, 2024 - 10:03 PDT
Identified
Our Engineering team has implemented a fix and we are seeing improvement, however we are still working on this and watching closely.
Posted Jul 25, 2024 - 09:15 PDT
Investigating
We are aware of issues that are causing issues with the Admin experience like password resets or subscription changes. Our Engineering team has already been working on this and will share updates here.
Posted Jul 25, 2024 - 08:17 PDT
This incident affected: Admin Experience.