Errors accessing or updating Tithely Sites

Incident Report for Tithe.ly

Resolved

This issue has been resolved by our Engineering team and all Sites are working as expected.
Posted Jun 15, 2026 - 04:37 PDT

Monitoring

We've implemented a fix and are seeing sites loading as expected, along with accessing the Sites through Tithely Dashboard
Posted Jun 15, 2026 - 04:22 PDT

Update

We're updating the scope of the issue as we're seeing that many Tithely Sites are not responding / loading. Our Engineering team is actively working to resolve and we will share updates on this page.
Posted Jun 15, 2026 - 04:08 PDT

Investigating

We are investigating reports of errors when accessing or updating some features of Tithely Sites.
Posted Jun 15, 2026 - 03:53 PDT
This incident affected: Admin Experience and Sites.