Elevated Errors across Tithely Products

Incident Report for Tithe.ly

Resolved

This was solved yesterday afternoon by our System provider.
Posted Oct 20, 2025 - 15:30 PDT

Monitoring

Our Engineering teams are continuing to monitor our products and ensure reliability. Our provider is seeing improvement, however they are still reporting issues.
Posted Oct 20, 2025 - 11:57 PDT

Investigating

Due to an issue occurring with a key system provider, we are noticing errors that are occurring for some customers. This could present as delays in email sends, or potentially errors attempting to process gifts. This is external to Tithely and our Engineering teams are monitoring closely.
Posted Oct 20, 2025 - 08:14 PDT
This incident affected: Giving (Admin Batch Giving, Giving App, Form, Transaction Processing) and Admin Experience, Messaging.