Identified Degraded Performance for [SERVICE]

Incident Report for Tithe.ly

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 22:07 PDT

Investigating

The scheduled maintenance has been completed. Thank you for your patience!
Posted Jul 30, 2026 - 22:07 PDT

Identified

System down for planned Maintenance Window. We’ll share another update shortly.
Posted Jul 30, 2026 - 21:10 PDT
This incident affected: Giving (Admin Batch Giving, Giving App, Form, Transaction Processing, Transaction Reporting, Pledge Campaigns) and Admin Experience, Media, People, Sites.