Investigating Partial Outage for Giving and People

Incident Report for Tithe.ly

Resolved

We have confirmed that this issue is fully resolved for our customers experiencing this!
Posted Feb 27, 2026 - 15:12 PST

Monitoring

Giving and People appear to be back up and running. We’re monitoring it closely to verify all issues are fully resolved. We’ll share another update shortly.
Posted Feb 27, 2026 - 12:52 PST

Identified

We’ve identified the issue causing the problem and are working to fix this as quickly as we can. We’ll share another update shortly.
Posted Feb 27, 2026 - 12:12 PST

Investigating

We’ve identified an issue with Giving that is impacting some users. We’re investigating the root problem right now. We’ll continue to share updates on our progress as we resolve this issue.
Posted Feb 27, 2026 - 11:08 PST
This incident affected: Giving (Giving App, Form, Transaction Processing) and People.