Issues Generating Tax Statements
Incident Report for Tithe.ly
Resolved
Our team has resolved the trouble with tax statements and we've confirmed that it's generating as expected now. Thank you for your patience!
Posted Jan 21, 2025 - 14:41 PST
Identified
We've identified the issue and are deploying a fix.
Posted Jan 21, 2025 - 14:11 PST
Investigating
We are aware of an issue that is preventing the generation of tax statements. Our Engineering team is aware and working to resolve this.
Posted Jan 21, 2025 - 14:00 PST
This incident affected: Admin Experience and Giving (Transaction Reporting).