Partial Outage for Giving Form Sign Up

Incident Report for Tithe.ly

Resolved

We’re back! Giving Form sign up should be up and running. Thanks for bearing with us.
Posted Aug 29, 2025 - 13:16 PDT

Monitoring

Giving Form sign up appears to be back up and running. We’re monitoring it closely to verify all issues are fully resolved. We’ll share another update shortly.
Posted Aug 29, 2025 - 13:04 PDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 29, 2025 - 11:43 PDT

Identified

We’ve identified the issue causing the problem and are working to fix this as quickly as we can. We’ll share another update shortly.
Posted Aug 29, 2025 - 10:28 PDT

Investigating

We’ve identified an issue with the Giving Form that is impacting some users attempting to sign up. We’re investigating the root problem right now. We’ll continue to share updates on our progress as we resolve this issue.
Posted Aug 29, 2025 - 10:14 PDT
This incident affected: Giving (Giving App, Form, Transaction Processing).