Church Apps dashboard cannot be accessed

Incident Report for Tithe.ly

Resolved

Apps Dashboards are now back up and running! Thank you for hanging in with us today as we worked to resolve the issue.
Posted Jul 15, 2026 - 07:29 PDT

Identified

The issue has been identified and we're working towards a fix!
Posted Jul 15, 2026 - 07:08 PDT

Investigating

We are aware of an issue where customers cannot access their Church Apps dashboard.
Posted Jul 15, 2026 - 06:40 PDT
This incident affected: Church Apps.