Limited Access Users unable to access Tithely

Incident Report for Tithe.ly

Resolved

We're happy to report that this issue is fully resolved and Limited Access Users are able to access as expected.
Posted Mar 20, 2025 - 13:10 PDT

Identified

We've identified the issue and are releasing a solution now.
Posted Mar 20, 2025 - 12:59 PDT

Investigating

We are aware of an issue occuring where Limited Access users are unable to access the Tithely Admin Experience. Our teams are investigating this now.
Posted Mar 20, 2025 - 12:50 PDT
This incident affected: Admin Experience.