Issues with updating sermon notes

Incident Report for Tithe.ly

Resolved

Issues with updating sermon notes should now be resolved! We apologize for any inconvenience this caused on Sunday morning!
Posted Jun 14, 2026 - 08:31 PDT

Identified

The issue has been identified and we are working quickly towards a resolution.
Posted Jun 14, 2026 - 08:05 PDT

Investigating

We are investigating a issue where sermon notes are not updating as expected this morning. Stay posted with us this morning as we share more details as we work toward a swift resolution to the issue.
Posted Jun 14, 2026 - 07:31 PDT
This incident affected: Church Apps.