Errors attempting to access Church Apps Dashboard

Incident Report for Tithe.ly

Resolved

We're happy to report that this issue is fully resolved and Admins should be able to access the Apps area with no issues.
Posted Feb 24, 2026 - 15:15 PST

Identified

The root problem has been identified and a fix is being implemented
Posted Feb 24, 2026 - 13:02 PST

Investigating

We're aware of an issue where some customers are experiencing troubles when attempting to access their Church Apps Dashboard from the Admin area. We're investigating this currently.
Posted Feb 24, 2026 - 12:11 PST
This incident affected: Admin Experience and Church Apps.