Church Apps Tabs and Layout Editor pages in Admin Dashboard are not loading

Incident Report for Tithe.ly

Resolved

This incident has been resolved. Apps back to 100% operational.
Posted Aug 26, 2025 - 13:05 PDT

Update

Continuing cache-removal process. New ETA for resolution - within the hour.
Posted Aug 26, 2025 - 12:18 PDT

Update

Issue was caused due to a system outage within Azure - ETA for resolution ~30 minutes.
Posted Aug 26, 2025 - 11:27 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 26, 2025 - 10:49 PDT

Update

We are continuing to investigate the issue. ETA on resolution - 2 hrs.
Posted Aug 26, 2025 - 09:57 PDT

Investigating

We are currently investigating an issue where the tabs and layout editor pages of the Church Apps admin dashboard are not loading as expected.
Posted Aug 26, 2025 - 09:25 PDT
This incident affected: Church Apps.