Issues loading Giving related pages
Incident Report for Tithe.ly
Resolved
This issue has been resolved by our Engineering teams and all pages are loading as expected now.
Posted Jun 05, 2023 - 08:18 PDT
Identified
We have identified the issue causing this and have implemented a fix. We are seeing improvement on the loading of these pages.
Posted Jun 05, 2023 - 08:15 PDT
Update
This issue is not affecting any giving processing, only the Giving Dashboard pages.
Posted Jun 05, 2023 - 07:55 PDT
Investigating
Our teams are currently investigating an issue affecting the loading of Giving related pages in the Admin section.
Posted Jun 05, 2023 - 07:52 PDT
This incident affected: Admin Experience and Giving (Giving App, Form, Transaction Processing).