Delays in Contribution Receipts
Incident Report for Tithe.ly
Resolved
We're happy to report that all receipts are caught up, and they are sending through as expected.
Posted Nov 18, 2024 - 05:35 PST
Monitoring
We are seeing that the majority of receipts have been sent and we are nearly caught up, however we'll keep monitoring for a bit longer.
Posted Nov 18, 2024 - 05:13 PST
Identified
Our teams are aware of an issue affecting the sending of receipts for donations. The root issue has been solved, however it will take several hours for all receipts to be processed. This has NOT affected any processing of donations, only the sending of receipts.
Posted Nov 18, 2024 - 04:00 PST
This incident affected: Giving (Giving App, Form, Transaction Processing).