Slow loading pages if you have background checks through MinistrySafe enabled

Incident Report for Tithe.ly

Resolved

The speed issue when loading background check and training modals has been resolved!
Posted May 19, 2026 - 09:39 PDT

Identified

We are currently investigating and have identified an issue where customers using MinistrySafe's background checks are finding slow loading people pages and background check modals.
Posted May 19, 2026 - 08:28 PDT
This incident affected: People.