Delays in some actions
Incident Report for Tithe.ly
Resolved
Our teams have been monitoring and can confirm that everything is has been functioning as expected with our implemented fix.
Posted Sep 04, 2024 - 19:15 PDT
Monitoring
Our team has solved the issue causing the problems. We do anticipate that it will take a bit longer to allow pending emails to be sent successfully.
Posted Sep 04, 2024 - 15:21 PDT
Investigating
We are aware of an issue where some Admin pages and tasks are being delayed. Our Engineering team have been engaged and working on this already. This is also affecting some emails such as password resets.
Posted Sep 04, 2024 - 14:25 PDT
This incident affected: Admin Experience and People.