Issues downgrading subscriptions
Incident Report for Tithe.ly
Resolved
This issue has been fully resolved.
Posted Dec 02, 2022 - 17:12 PST
Investigating
We are investigating an issue affecting the ability to downgrade a subscription.
Posted Dec 02, 2022 - 14:50 PST
This incident affected: Admin Experience.