The Maintenance is proceeding according to plan and the Engineering teams are currently verifying functionality prior to disabling Maintenance Mode.
Posted Oct 30, 2025 - 21:13 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 30, 2025 - 21:00 PDT
Scheduled
This evening our Engineering teams will be performing a Maintenance for Tithely Giving that will require a brief outage. This will be Thursday, October 30th at 9:00pm for up to 30 minutes.
Here’s what to expect during the maintenance window: During this time, a maintenance page will display on Giving Forms, the Giving App, and within your account to communicate that Giving is temporarily unavailable You will not be able to log in to your account to perform any updates or changes. Attempts to donate using Tithely Giving will not be successful. Any recurring gifts scheduled to process during the maintenance will be processed afterwards.
Maintenance Window in different timezones - US Pacific Time (UTC-7) Thursday, October 30, 2025 9:00-9:30pm - US Eastern Time (UTC-4) Friday, October 31, 2025 12:00-12:30am - UTC (UTC+0) Friday, October 31, 2025 4:00-4:30am - Singapore (UTC+8) Friday, October 31, 2025 12:00-12:30pm - Australian Eastern (UTC+11) Friday, October 31, 2025 3:00-3:30pm